Opened 8 years ago

Closed 7 years ago

#939 closed defect (fixed)

Integrity constraint violation beim Verschieben einer Seite

Reported by: michael.ritter Owned by: comvation
Priority: normal Milestone: Contrexx 3.0 SP3
Component: ContentManager Version: 3.0.0
Severity: normal Keywords:
Cc:

Description (last modified by thomas.daeppen)

Beim Verschieben einer Seite im ContentManager erscheint die Meldung SQLSTATE[...]: Integrity constraint violation: [...] Duplicate entry '[...] Cx\Model\ContentManager\Page' for Key [...]

Diese Meldung erscheint, weil versucht wird zwei Log Einträge mit der gleichen Versionsnummer zu erstellen.

Change History (6)

comment:1 Changed 8 years ago by michael.ritter

Wir benötigen einen reproduzierbaren Fall, um weiter Testen zu können. Offensichtlich sind die Implementationen der Methode Gedmo\Loggable\Mapping\Event\LoggableAdapter?->getNewVersion() nicht über alle Zweifel erhaben.

comment:2 Changed 7 years ago by michael.raess

  • Owner changed from comvation to michael.raess

comment:3 Changed 7 years ago by michael.raess

  • Milestone changed from unknown to Contrexx 3.0 SP3

comment:4 Changed 7 years ago by thomas.daeppen

  • Description modified (diff)
  • Owner changed from michael.raess to comvation

comment:5 Changed 7 years ago by thomas.daeppen

  • Milestone changed from Contrexx 3.0 SP3 to Contrexx 3.0 SP4

comment:6 Changed 7 years ago by thomas.daeppen

  • Milestone changed from Contrexx 3.0 SP5 to Contrexx 3.0 SP3
  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #1070

Note: See TracTickets for help on using tickets.