Opened 11 years ago

Closed 7 years ago

#504 closed defect (duplicate)

Navigationspunkte werden nicht ausgegeben

Reported by: thomas.daeppen Owned by: michael.ritter
Priority: normal Milestone: Contrexx 3.0 SP5
Component: Core Version: 2.1
Severity: normal Keywords:
Cc:

Description (last modified by thomas.daeppen)

Es besteht die folgende Navigationsstruktur:

  • Seite 1 (unsichtbar)
    • Seite 2 (sichtbar)
    • Seite 3 (sichtbar)

Beim Anzeigen der Seite 1 werden die Unterseiten 2 und 3 in der (Sub)Navigation aufgelistet. Wird nun die Seite 2 oder 3 angezeigt, so werden diese in der (Sub)Navigation nicht mehr aufgelistet.

Das Problem liegt daran, dass beim auslesen der Navigationsstruktur nur sichtbare Seiten ausgelesen/berücksichtigt werden. Ist die übergeordnete Seite nun unsichtbar, so wird diese nicht ausgelesen. Dies hat zur Folge, dass die aufgerufene Seite (und andere Seiten auf demselben Navigationslevel) bei der Navigationsstruktur nicht eingefügt werden kann, da die übergeordnete Seite ja nun fehlt.

Lösungsansatz: Anstatt nur die sichtbaren Seiten auslesen, alle Seiten auslesen und anschliessen rekursiv alle Übergeordneten Seiten der aufgerufenen Seite ausfindig machen.

Attachments (1)

bug.png (9.6 KB) - added by michael.ritter 7 years ago.
Picture by Pathab, see http://bugs.contrexx.com/contrexx/ticket/1379

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by thomas.daeppen

  • Description modified (diff)

Changed 7 years ago by michael.ritter

comment:2 Changed 7 years ago by michael.ritter

  • Milestone changed from Contrexx 3.0 (old) to Contrexx 3.0 SP4

Problem remains for 3.0+ version, as reported by Pathab, see http://bugs.contrexx.com/contrexx/ticket/1379

comment:3 Changed 7 years ago by michael.ritter

  • Owner changed from comvation to michael.ritter
  • Status changed from new to assigned

comment:4 Changed 7 years ago by michael.ritter

Probably a duplicate of http://bugs.contrexx.com/contrexx/ticket/1412 or http://bugs.contrexx.com/contrexx/ticket/1043

Waiting for further information from customer.

comment:5 Changed 7 years ago by michael.ritter

  • Resolution set to duplicate
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.