Opened 7 years ago

Closed 7 years ago

#1572 closed defect (wontfix)

Upload of files containing quotes does not work

Reported by: michael.ritter Owned by: michael.ritter
Priority: normal Milestone: Contrexx 3.1
Component: Upload Version: 3.0.4
Severity: normal Keywords:
Cc:

Description

Uploader cannot handle files containing single and double quotes. This can be reproduced in modules/gallery (see also #1531)

Change History (4)

comment:1 Changed 7 years ago by michael.ritter

  • Owner changed from comvation to michael.ritter
  • Status changed from new to assigned

comment:2 Changed 7 years ago by michael.ritter

Depending on which browser and which uploader is used, problem expresses itself differently:

Opera seems to strip everything after the first quote in the filename, causing different problems:

  • Form uploader: File cannot be uploaded because it is not found locally
  • Java uploader: Upload seems to work, but file is never written (probably because Opera does not supply a filename)
  • Flash uploader: Same as for Java

Chrome seems to rename the file, this leads to a successful upload with a wrong filename.

comment:3 Changed 7 years ago by michael.ritter

Firefox seems to strip all unwanted characters which again leads to a successful upload with a wrong filename...

comment:4 Changed 7 years ago by michael.ritter

  • Resolution set to wontfix
  • Status changed from assigned to closed

This can/will not be fixed by us since its mostly a browser problem

Note: See TracTickets for help on using tickets.