Opened 7 years ago

Closed 7 years ago

#1472 closed defect (duplicate)

Rewriterule for Old Apache Compatibility Does Not Work on Some Hostings

Reported by: reto.kohli Owned by: comvation
Priority: normal Milestone: Contrexx 3.1
Component: Routing Version: 3.0.3
Severity: normal Keywords: rewriterule apache compatibility redirect
Cc:

Description

On some hostings, e.g. Hostpoint servers, the following line causes neverending redirects:

# Remove trailing slash for old Apaches (newer ones stop rewriting when result matches request)

RewriteRule? (\w\w\/)?(_meta|admin|cache|cadmin|changelog|config|core|core_modules|customizing|feed|images|installer|lang|lib|media|model|modules|testing|themes|tmp|update|webcam|favicon.ico|mysqldumper)\/$ $2 [L,QSA]

This may be fixed by uncommenting or removing it.

Change History (2)

comment:1 Changed 7 years ago by reto.kohli

It seems that the problem appears after those servers have been upgraded with new PHP and, very likely, due to new Apache versions.

comment:2 Changed 7 years ago by thomas.daeppen

  • Component changed from other(specify) to core/Routing
  • Milestone changed from Contrexx 3.0 SP5 to Contrexx 3.1
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #957

Note: See TracTickets for help on using tickets.